Welcome to the forum!

As an adjunct to the Tangents blog, the intention with this forum is to answer any questions, and allow a diverse discussion of topics related photography. With that, see it as an open invitation to just climb in and start threads and to respond to any threads.

Revisiting the Nikon D700/SB-900 Hot Shoe Stroboscopic Problem

jcalex3642jcalex3642 Member
edited January 2014 in home
There are several long threads on various forums describing the intermittent and unexpected (strobe-like) firing of the SB-900 when used on the D700. The consensus seems to be that it’s a D700 hot shoe problem rather than an SB-900 problem – and that the weight of the SB-900, in tandem with the continual moving and torque applied to the flash head to achieve various flash bounce angles ultimately “loosens” the hot shoe contacts enough to cause the problem. Oxidation of the mating contacts is also cited as a non-trivial contributor. After reading awhile, it becomes surprisingly obvious that this is happening to a substantial number of photographers using this camera/flash combo. Suggestions for fixing the problem range from bending the D700 hot shoe rails with a hammer, using pliers to squeeze the rails, using Radio Shacks contact de-oxidizing agent, and using Nikons moisture-protecting device (WG-AS3) around the hot shoe to add some stability for the flash. None of these remedies seems to offer 100% protection from this problem when said flash is mounted on the camera’s hot shoe. Quite a few users have resorted to sending the camera to a Nikon repair station and requesting a hot shoe replacement. One gets the feeling that it’s not if the problem is going to occur, but rather when! (even with a hot shoe replacement). This is especially true for wedding photographers (using the D700/SB-900) who are continuously moving the flash head to get different bounce angles. Nikon, apparently, does not acknowledge a design fault when this problem is addressed with them.

I use the D700/SB-900, and I have experienced this random strobe flash a number of times. It’s perplexing and very discouraging – to the point of totally losing confidence in the combo when shooting important events.

My question is…has anyone on this forum become so disillusioned with the questionable reliability of this system that they have simply resorted to taking the SB-900 off the D700 and using the SC-29 to connect camera and flash using a flash bracket? If so, how successful has this been? Did it solve the problem? Bracket used (or recommended)? Any other suggestions. I'm just about at wits end trying to solve this problem and finding a reliable solution.

Comments

  • I've had it happen on both my D700s which I keep hanging upside down from a belt. They were both fixed under Grays' long term warranty by Fixation (at least I think it was Fixation) two years and four years ago, and both have been absolutely fine since.

    This suggests to me that there is a chance that the replaced hotshoe may just be more durable than the original. It's just possible that newer D700s are better.

    So my suggestion would be, if you haven't had a repair, get a quote from Fixation (I had the second one serviced and all external rubbers replaced at the same time) and get them to sort it for you.



  • Thanks for the suggestion, John, I may, indeed, pursue that route.
  • Hi Jcalex,
    I would take this issue of yours and use it as a positive. I know lots of people don't like brackets, however I feel like I saw a real improvement in my flash photography once I was able to always keep the flash above the camera axis ...a bracket might be your new best friend and solve your problem and the same time.
    I use a custom bracket.....and have also used it with my D700, works great easy to hold, LOVE it.
    Best of luck!
  • Thanks for your comments, ShutterEyes. I believe a bracket is warranted here as well.
    Regards, jcalex
  • I had this problem two years ago, and I sent to an authorized Nikon repair shop, and they replaced the hotshoe parts. I haven't had the problem happen again.

    This is definitely a design flaw, since the added weight of the SB-900 was not adequately tested against older cameras at the time of its release (in this case, the D700). I believe that cameras older than D700 would suffer the same problem, but since there are fewer of them out there in full-time use, few people would notice.

    If you have ever read bythom.com, Nikon has a bad history of not acknowledging design flaws. If there is a design flaw, Nikon often chooses to release a slightly updated version (e.g. D600 to D610, SB-900 to SB-910).
  • Yes, I had this problem. As per other posts above authorised Nikon repair centre has done the trick (touch wood). Fixation if UK based.
  • I had exactly the same problem with the D700 / SB900 combo - took them in for repairs at Nikon South Africa - some rubbers were replaced, but not the hot shoes. Still waiting for them to be returned though, haven't been able to test them.
Sign In or Register to comment.