Welcome to the forum!

As an adjunct to the Tangents blog, the intention with this forum is to answer any questions, and allow a diverse discussion of topics related photography. With that, see it as an open invitation to just climb in and start threads and to respond to any threads.

Pocket wizard mini and flex issues ?

Anyone ever have any issues? I've had them for a year now and never any issues before. Recently, my tt1 has been causing my d700 flash symbol to blink and it won't fire. Cleaned the contacts and re seat - works.... My pair of tt5's. Great triggers...... Every set of batteries I put in unless it's alkaline - after 5 mins blink orange and 5 mins after, red. Gives me about 10 mins working time at best. Anyone else have issues ? I'm ready to call pocket wizard tomorrow.

Comments

  • Neil vNNeil vN Administrator
    First step = make sure your software is up to date!  This is hugely important with the TT1 and TT5 units. 

    Let us know if that solves the issue? 
  • Hi Neil - thanks for the comment. Yes they are up to date with software. When the issue first happened I made sure to reset and update them. I charged all the batteries and made sure they work. I switched the tt1 for one of my tt5's and it was the same issue. I will say this, with the tt1, I used a pencil eraser and cleaned to contacts and it seemed to work. Not so much with the tt5. Even my d700 firmware is up to date. It's just confusing since they used to work flawlessly.
  • Neil vNNeil vN Administrator
    Definitely contact the PocketWizard distributors to check these out - especially because they kill your batteries so quickly. There's something wrong there!
  • MikeZMikeZ Member
    edited October 2015
    I had to forego the TT1 per Pocketwizard's recommendation. I had nothing but issues with the TT1 and the 700. All firmware updated. PW took the TT1 back and sent me a TT5 at no extra cost. 
    If I tried to use the TT1 the camera would act like no lens was attached. To be honest...I love having 3 TT5's. No oddball battery.
     
  • Somehow I missed the responses. I dont know what happened but I was able to contact them. I had to do the two button hard reset and it works now. Kind of odd how funky things got for a while. As far as batteries, now i have no issues. Thanks for the help!
Sign In or Register to comment.