Welcome to the forum!

As an adjunct to the Tangents blog, the intention with this forum is to answer any questions, and allow a diverse discussion of topics related photography. With that, see it as an open invitation to just climb in and start threads and to respond to any threads.

Odd LR and Canon DPP Problem

Hi - I have raw files from a recent vacation, and I couldn't remember if I had worked on them or not in LR. I went to the directory, and looked at the raw files, but it was with Canon DPP, which seems to be the default when doing this. I determined they hadn't been worked on, and went into LR,, and can see them in the "library" mode. When I went into "develop" mode, LR gives me a message "This file cannot be found". I thought raw was raw, and if I opened something in DPP, I would still be able to wokr on it in LR. I tried to copy, move, etc. How come this is happening?

Dave

Comments

  • I think - never mind - but I'll get back to you. There are like 6 files (out of 64) that for some reason can't be found. I don't think it's a LR/DPP problem, but I'm not sure yet what happened.

    Dave
  • My bad. False alarm. I had taken 6 photos before I realized I was shooting Jpeg. Those 6 got moved to the "processed" folder. oooops.
  • TrevTrev Moderator
    Glad I could help.... (Love it when one solves one's own mistake)
  • Neil vNNeil vN Administrator
    This is why we're here. Heh. 
  • So, I did find an issue that is sort of the same. When I try to open a RAW file with DPP that has previously been opened in LR, I get an error box that reads "decoding failed". The way I try this is by going to the directory where the files are kept, and right clicking the mouse to get the menu selection "open with". LR and DPP are available options, but DPP gives an error.

    The reason why I would want to do this would be to look at a certain file without starting LR. DPP starts much easier and is quicker just to see what is contained in a particular file.

    Does LR do something to the RAW file that causes this?
  • TrevTrev Moderator

    Dave,

    The answer sould be no, LR does not do anything to the actual file. When opened in LR, it creates a library and thumbnail, and any settings are embedded within LR Catalogue/Library.

    Even when you delete the Library file with all adjustments, it does not touch the raw, it only kind of 'looks' at the raw file's location.

    Of course if you change name/delete/move that raw file from the folder next time you open LR it will be 'Offline/Missing' naturally.

    Have you opened DPP then import the said problem file, instead of just choosing Open With.

    I don't have DPP but cannot see any reason it won't open a RAW.

    When I have opened RAWs in LR, I can still open that file in ACR/Capture One, and Faststone Viewer & Bridge, no problems, so should be the same for DPP I would think.

    But hey, it's Canon's own proprietary software so anything is possible. Try opening DPP first as I said then 'Import' see if it works that way.

    Unless you have somehow set up LR to embed all settings within the RAW so any adjustments may not be compatible, but I don't see how you did as it's just all in a Library/Catalogue.

    Trev


  • OK, Trev I will try those things. It was just odd to me. I don't use DPP any longer, really, because I have LR. But as I wrote, to me it's just a quicker way to look at a file and see what it is.

    Dave
  • Trev - just tried opening DPP and looking at a folder of RAW files that I processed using LR. 168 boxes with a big "X" through them. It's not a big deal, just curious. It's either Canon not liking the situation, or I've done something strange to the RAW files via LR. I'm hoping it's Canon.

    Dave
  • TrevTrev Moderator
    edited April 2016
    Dave,

    If you want to just look at a RAW file, why not get Microsoft's Camera Codec Pack, it enables you to view the RAW's embedded jpeg file in a normal Window's Explorer window.

    If you have Windows that is.

    Here is a file I uploaded, suits Windows 64 bit though.

    MICROSOFT CAMERA CODEC PACK-x64

    If you need 32-bit, just Google Microsoft Camera Codec Pack and choose your poison.


    Oh, that file I uploaded is from late 2014, so if you have any newer Camera Models like a Nikon D5, then you will need to get the latest version - HERE

    Trev.

    image
  • Thanks, Trev. I'll give that a try. - Dave
  • Neil vNNeil vN Administrator
    Just double check that your version of DPP can actually open those RAW files. 
    Do a few test shots, and pull them onto your hard drive in a test folder, and then try to open them with DPP. 

    I'm wondering if you might not be using an outdated version of DPP ? 
  • I haven't tried what you suggest, but before I got LR, I was using DPP to process. I'll try what you suggest.

    Thanks - Dave
Sign In or Register to comment.